ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration Supporthow to ensure both versions of mq will run without anyissue

Post new topicReply to topic
how to ensure both versions of mq will run without anyissue View previous topic :: View next topic
Author Message
saneben
PostPosted: Sun May 26, 2019 12:51 am Post subject: how to ensure both versions of mq will run without anyissue Reply with quote

Voyager

Joined: 04 Apr 2004
Posts: 87

Hi,

we have an old IBM MQ V7.0.1.3 running an legacy application we cannot upgrade this mq to the latest mq version.

so we have deceide to install the latest version of mq on the same unix box.

So to acheive this first i have to upgrade mq existing MQ V7.0.1.3 to 7.0.1.6
then install the new version on the same box is it?

can you please post some links about the this set up.

Regards
Sanjiv
Back to top
View user's profile Send private message
bruce2359
PostPosted: Sun May 26, 2019 4:46 am Post subject: Re: how to ensure both versions of mq will run without anyi Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8388
Location: US: west coast, almost. Otherwise, enroute.

saneben wrote:
can you please post some links about the this set up.

Regards
Sanjiv

Go to Google. Enter this search argument 'ibm mq multiple versions'.
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
saneben
PostPosted: Sun May 26, 2019 5:23 am Post subject: Reply with quote

Voyager

Joined: 04 Apr 2004
Posts: 87

https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_7.5.0/com.ibm.mq.pla.doc/q005730_copy.htm

I have got the link there are some restrictions as below can I install the new version of MQ ( in other words I do not want any issue with the existing mq)
due to the installation of new mq.


One installation can be an installation of IBM WebSphere MQ Version 7.0.1 at fix pack 6, or later. You now have a choice:
Keep the simplicity of maintaining and managing a single installation of IBM WebSphere MQ on a machine.
Take advantage of the flexibility offered by enabling multiple IBM WebSphere MQ installations.
Before you install multiple copies of IBM WebSphere MQ, you must make several decisions:
Will you have a copy of IBM WebSphere MQ Version 7.0.1 on the system?

When IBM WebSphere MQ Version 7.0.1 at fix pack 6, or later, is installed on the system, there are a number of restrictions to consider:
On UNIX and Linux systems, IBM WebSphere MQ Version 7.0.1 must be installed in the default location.
IBM WebSphere MQ Version 7.0.1 must be the first installation on a system. You cannot install IBM WebSphere MQ Version 7.0.1 after installing version 7.1, or later. If you uninstall version 7.0.1, it cannot be reinstalled while a later version of WebSphere MQ is installed.
IBM WebSphere MQ Version 7.0.1 is automatically the primary installation. You cannot select another installation as the primary installation while IBM WebSphere MQ Version 7.0.1 is installed.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Sun May 26, 2019 6:04 am Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8388
Location: US: west coast, almost. Otherwise, enroute.

Ok. Keep searching for how-to implement multi-versions. Create a TEST environment to practice.

Sorry, no one can guarantee no issues will arise. Make sure you also have a fallback plan.
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Sun May 26, 2019 8:43 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19991
Location: LI,NY

bruce2359 wrote:
Ok. Keep searching for how-to implement multi-versions. Create a TEST environment to practice.

Sorry, no one can guarantee no issues will arise. Make sure you also have a fallback plan.

and remember that before working with any of the other versions, you'll need to source the environment using setmqenv...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
saneben
PostPosted: Tue May 28, 2019 2:07 am Post subject: Reply with quote

Voyager

Joined: 04 Apr 2004
Posts: 87

Thanks for your replies now I have old mq 7.0.1.6 and mq 9.0.1

should I have to use the setmqenv


https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_7.5.0/com.ibm.mq.ref.adm.doc/q083560_.htm
Back to top
View user's profile Send private message
hughson
PostPosted: Tue May 28, 2019 11:59 am Post subject: Reply with quote

Grand Master

Joined: 09 May 2013
Posts: 1113
Location: Bay of Plenty, New Zealand

saneben wrote:
should I have to use the setmqenv


MQ V7.0.1.6 is your primary installation. To use this, you will not need to use setmqenv.

If you wish to use the MQ V9.0.1 installation, then yes, you will need to use setmqenv.

Cheers,
Morag
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration Supporthow to ensure both versions of mq will run without anyissue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.