ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportNot able to enable httpNodesUseEmbeddedListener in IBM ACE

Post new topicReply to topic
Not able to enable httpNodesUseEmbeddedListener in IBM ACE View previous topic :: View next topic
Author Message
rajeshraj
PostPosted: Mon Feb 04, 2019 12:20 am Post subject: Not able to enable httpNodesUseEmbeddedListener in IBM ACE Reply with quote

Newbie

Joined: 21 Apr 2017
Posts: 4

Hi,

I tried to execute below command to enable httpNodesUseEmbeddedListener for one of the integration servers running in IBM App connect enterprise version 11.0.0.3 but not able to make the property true.

C:\Program Files\IBM\ACE\11.0.0.3>mqsichangeproperties LOCAL_BRK_01 -e maximoservice -n httpNodesUseEmbeddedListener -v true -o ExecutionGroup

BIP8384E: This command, with the flag or combination of flags 'e', is not yet enabled for use with an integration node.
Although commands can be used with integration nodes, some flags or combinations of flags will not be enabled until a later fix pack.
Users of the product in its current form can use this command with other flags or combination of flags, and can perform some actions in the Enterprise Toolkit.

C:\Program Files\IBM\ACE\11.0.0.3>mqsireportproperties LOCAL_BRK_01 -e maximoservice -o ExecutionGroup -r

ExecutionGroup
activeUserExitList=''
failedMessageWaitTime='1000'
httpNodesUseEmbeddedListener='false'
identifier='00000000-0000-0000-0000-000000000000'
inactiveUserExitList=''
injectionMode='false'
name='maximoservice'
processorArchitecture='64'
soapNodesUseEmbeddedListener='true'
threadLocalProxyNameManagers='false'
traceNodeLevel='true'
type='ExecutionGroup'
unnamedTraceLevel='none'
unnamedUserTraceLevel='none'

Has anyone faced this problem ?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Mon Feb 04, 2019 7:08 pm Post subject: Re: Not able to enable httpNodesUseEmbeddedListener in IBM A Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19880
Location: LI,NY

rajeshraj wrote:
Hi,

I tried to execute below command to enable httpNodesUseEmbeddedListener for one of the integration servers running in IBM App connect enterprise version 11.0.0.3 but not able to make the property true.

C:\Program Files\IBM\ACE\11.0.0.3>mqsichangeproperties LOCAL_BRK_01 -e maximoservice -n httpNodesUseEmbeddedListener -v true -o ExecutionGroup

BIP8384E: This command, with the flag or combination of flags 'e', is not yet enabled for use with an integration node.
Although commands can be used with integration nodes, some flags or combinations of flags will not be enabled until a later fix pack.
Users of the product in its current form can use this command with other flags or combination of flags, and can perform some actions in the Enterprise Toolkit.

C:\Program Files\IBM\ACE\11.0.0.3>mqsireportproperties LOCAL_BRK_01 -e maximoservice -o ExecutionGroup -r

ExecutionGroup
activeUserExitList=''
failedMessageWaitTime='1000'
httpNodesUseEmbeddedListener='false'
identifier='00000000-0000-0000-0000-000000000000'
inactiveUserExitList=''
injectionMode='false'
name='maximoservice'
processorArchitecture='64'
soapNodesUseEmbeddedListener='true'
threadLocalProxyNameManagers='false'
traceNodeLevel='true'
type='ExecutionGroup'
unnamedTraceLevel='none'
unnamedUserTraceLevel='none'

Has anyone faced this problem ?

What happens if you drop the -o ExecutionGroup

_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
rajeshraj
PostPosted: Tue Feb 05, 2019 1:27 am Post subject: Reply with quote

Newbie

Joined: 21 Apr 2017
Posts: 4

-o is a mandatory paramter.

C:\Program Files\IBM\ACE\11.0.0.3>mqsichangeproperties LOCAL_BRK_01 -e maximoservice -n httpNodesUseEmbeddedListener -v true
BIP8123W: The mqsichangeproperties command changes the values of integration node properties.
Syntax 1:
mqsichangeproperties integrationNodeName ( -b NodeHttpListener | -b SecurityCache | -b RestAdminListener | -b CacheManager | -b Events | -e integrationServerName | -c policyName ) -o ObjectName -n PropertyName ( -v PropertyValue | -d | -p Path/Filename ) [-f]
Syntax 2:
mqsichangeproperties integrationNodeName ( -o BrokerRegistry | -o SecurityCache | -o CacheManager | -o RestAdminListener ) -n PropertyName ( -v PropertyValue | -d | -p Path/Filename ) [-f]

Command options:
integrationNodeName: The name of the integration node to modify.
'-b NodeHttpListener': Change properties for the HTTP Listener component.
'-b SecurityCache': Change properties for the Security Cache component.
'-b RestAdminListener' Change properties for the Web Administration component.
'-b CacheManager' Change properties for the Cache Manager component.
'-b Events' Report properties for the Publish/Subscribe component.
'-e integrationServerName' Change properties for the integration server.
'-c policyName' Change properties for a policy used by the integration node, such as JMSProviders.
'-o objectName' The name of the object for which you want to change the properties.
'-n propertyName' The name of the property to be changed.
'-v propertyValue' The value that is assigned to the property specified by the -n parameter. Specify more than one property name and corresponding value by using commas as separators; for example, -n Name1, Name2 -v Value1, Value2.
'-d' If the property that you specify on the -n parameter exists, it is deleted. This parameter is valid only if you specify a policy of type UserDefined.
'-p path/filename' The name of a file to read the integration node property settings from.
'-f' Allow the command to run when the integration server stopped. Use this option only for recovering from integration server startup failures and only with the -e option.

BIP8006E: Flag missing. One of the flags in list (object) must be specified.
When using this command interface the user should select all required flags.
Correct and reissue the command.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Feb 06, 2019 3:36 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19880
Location: LI,NY

Change the order of your parameters.
Put the -o ExecutionGroup directly after -e integration server...
Code:
mqsichangeproperties LOCAL_BRK_01 -e maximoservice -o ExecutionGroup -n httpNodesUseEmbeddedListener -v true

Although looking at:
Quote:
BIP8384E: This command, with the flag or combination of flags 'e', is not yet enabled for use with an integration node.
Although commands can be used with integration nodes, some flags or combinations of flags will not be enabled until a later fix pack.
Users of the product in its current form can use this command with other flags or combination of flags, and can perform some actions in the Enterprise Toolkit.
the answer is maybe fixpack 4 ??
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportNot able to enable httpNodesUseEmbeddedListener in IBM ACE
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.