ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportSNIExtension disbalement

Post new topicReply to topic
SNIExtension disbalement View previous topic :: View next topic
Author Message
sumitabc2212
PostPosted: Thu Apr 20, 2017 12:00 pm Post subject: SNIExtension disbalement Reply with quote

Newbie

Joined: 17 Oct 2011
Posts: 4
Location: Connecticut USA

Hi, I am trying to disable the Server Name Identification(SNI) check in IIB 9, which I guess is true by default, but don't know where do I need to change this in broker. Can anyone help me on this please?
Back to top
View user's profile Send private message
mqjeff
PostPosted: Thu Apr 20, 2017 12:20 pm Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

You'll need to be at 9.0.0.6 minimum to even use SNI
http://www-01.ibm.com/support/docview.wss?uid=swg1IT14330

The 9.0.0.7 Knowledge Center doesn't seem to have any specific information about SNI configuration, though.

So you might open a PMR that references that APAR, and see if there's follow up information or "undocmented" configuration that can be done - other than reverting back to 9.0.0.5.
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
sumitabc2212
PostPosted: Thu Apr 20, 2017 12:30 pm Post subject: SNIExtension disbalement Reply with quote

Newbie

Joined: 17 Oct 2011
Posts: 4
Location: Connecticut USA

Thank you for your response. We recently upgraded to 9.0.0.7 and after that we are getting an error "javax.net.ssl.SSLProtocolException: handshake alert: unrecognized_name" while calling a web service which used to work earlier. On doing some investigation on this I came to know cause can be SNI check which is new feature in Java 1.7 and the default value is true in broker but I was not able to find a way to disable it.

I will raise a PMR with IBM for this.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportSNIExtension disbalement
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.