ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Process Server (WID/WPS/WAS+)Updating entire EAR using JACL fails?

Post new topicReply to topic
Updating entire EAR using JACL fails? View previous topic :: View next topic
Author Message
sleepyjamie
PostPosted: Mon Dec 07, 2015 8:12 am Post subject: Updating entire EAR using JACL fails? Reply with quote

Centurion

Joined: 29 Apr 2015
Posts: 135

I'm trying to update an existing EAR using JACL and wsadmin from command line. I've read the documentation and everything appears to be correct.

https://www-01.ibm.com/support/knowledgecenter/SSAW57_8.0.0/com.ibm.websphere.nd.doc/info/ae/ae/rxml_adminapp.html?lang=en

Here is my command:


/opt/ibm/WebSphere/AppServer/bin/wsadmin.sh -user userName -password somePassword -host localhost -port 8879 -c "$AdminApp update app1 app {-operation update -contents /home/jamie/myApp.ear}"


Here is the error message from wsadmin:


WASX7209I: Connected to process "dmgr" on node DmgrNode-SIT using SOAP connector; The type of process is: DeploymentManager
WASX7015E: Exception running command: "update app1 app {-operation update -contents /home/jamie/myApp.ear}"; exception informat ion:
com.ibm.bsf.BSFException: error while eval'ing Jacl expression:
wrong # args: should be "update ?idletasks?"
while executing
"update app1 app {-operation update -contents /home/jamie/myApp.ear}"


According to the documentation and samples everything appears correct, however it is complaining about wrong number of arguments.
Back to top
View user's profile Send private message
zbyszanna
PostPosted: Mon Dec 28, 2015 4:15 am Post subject: Reply with quote

Novice

Joined: 03 Feb 2012
Posts: 22

Use \$ instead of $. The dollar sign is interpreted by your shell and $AdminApp is replaced with an empty string.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Process Server (WID/WPS/WAS+)Updating entire EAR using JACL fails?
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.