ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexUser ExitsMsgExit for V6 not Working on V7

Post new topicReply to topic
MsgExit for V6 not Working on V7 View previous topic :: View next topic
Author Message
Gogol
PostPosted: Wed Sep 12, 2012 10:46 pm Post subject: MsgExit for V6 not Working on V7 Reply with quote

Newbie

Joined: 16 Jul 2012
Posts: 8

Hello Everybody,

We had a MsgExit on MQv6 on SDR Channel that I think copies the msgId to correlId of the messages that are sent to Tandem systems, as the Tandem programs are not written in a way to do this. But the exit is not working in MQv7 and also after sometime I notice that the channel goes into SubState(MQMsgExit) while STATUS(RUNNING) , but messages piles up in the XMITQ. Once I remove the MsgExit and start the channel again, the messages flows.

Application reading the messages can not read them as the messages does not have anything in their correlId, and application are written to read the messages based on correlId.

Also application are connecting through SVRCONN Channel which connects and then disconnects with in the same second though there are no exits in SVRCONN channels. No Error in MQ errors. The application shows 2033 within a second while they are coded to wait for 4 seconds. I really dont understand ''

Is there any change in the way MQv7 correlId should be accessed by MQ exits or they are the same like MQv6 ?

What could be the reason that the SDR channel runs for sometime and then messages starts piling up in XMITQ?

Can the MsgExit in SDR channels force the SVRCONN to exit?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Sep 13, 2012 5:16 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19397
Location: LI,NY

I assume here that the msg exit has been recompiled with the V7 libraries for both 32 bit and 64 bit right?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Gogol
PostPosted: Sat Sep 15, 2012 2:53 am Post subject: Hi fjb_Saber Reply with quote

Newbie

Joined: 16 Jul 2012
Posts: 8

Hi fjb_Saber,

No it's not compiled again as we dont have the source code, the exit is a third party exit, and I am trying to get them to fix this, but don't see any possibility. I just have the pre compiled exit, which works on one of the same specification Tandem Channel , but not in the problematic channel.. I don't see any difference in the channel properties apart from conname...

The exit just gets stuck and the substate becomes MSGEXIT while channel is RUNNING, but XMITQ is loaded with many messages and increasing.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Sat Sep 15, 2012 6:57 am Post subject: Re: Hi fjb_Saber Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19397
Location: LI,NY

Gogol wrote:
Hi fjb_Saber,

No it's not compiled again as we dont have the source code, the exit is a third party exit, and I am trying to get them to fix this, but don't see any possibility. I just have the pre compiled exit, which works on one of the same specification Tandem Channel , but not in the problematic channel.. I don't see any difference in the channel properties apart from conname...

The exit just gets stuck and the substate becomes MSGEXIT while channel is RUNNING, but XMITQ is loaded with many messages and increasing.

Well you need to recompile with the 7 libraries or ditch the exit.
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Gogol
PostPosted: Sun Sep 16, 2012 2:51 am Post subject: Thanks fjb_saper Reply with quote

Newbie

Joined: 16 Jul 2012
Posts: 8

Let me try that out and see what awaits... Thanks Again

Regards
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexUser ExitsMsgExit for V6 not Working on V7
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.