ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere DataPowerDuplicate response in conditional rule - XI50

Post new topicReply to topic
Duplicate response in conditional rule - XI50 View previous topic :: View next topic
Author Message
meaton78
PostPosted: Thu Jul 14, 2011 5:20 am Post subject: Duplicate response in conditional rule - XI50 Reply with quote

Centurion

Joined: 16 Oct 2008
Posts: 100

I have a very basic response rule in my Web Service Proxy that uses xpath to check for a value, and then based on that value it transforms the xml response. However, the response that I get has the xml in it twice. I've tested with a straight transform and it works fine, it only duplicates when I add the conditional rule.
To test further, in my conditional rule, I only add one xpath argument with one transform rule, and it still sends back the xml twice. If I use the probe, I see the valid response that I expect.
I'm totally stumped on this one. Any help or advice would be greatly appreciated.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere DataPowerDuplicate response in conditional rule - XI50
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.