ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP8081 & Broker isn't running but its service is starte

Post new topicReply to topic
BIP8081 & Broker isn't running but its service is starte View previous topic :: View next topic
Author Message
NewYa3am
PostPosted: Wed Oct 14, 2009 7:20 am Post subject: BIP8081 & Broker isn't running but its service is starte Reply with quote

Newbie

Joined: 14 Oct 2009
Posts: 8

Hello,

I've Windows XP Professional SP2.

I also have the following installed:

WebSphere Eclipse Platform V3.0.1
WebSphere MQ V6.0.0
ODBC Drivers for Apache Derby
WebSphere Message Broker, V6.1.0.0
WebSphere Message Broker Toolkit, V6.1.0

I've successfully run the default configuration wizard from the toolkit. I've checked windows services and found that the following services are started:

IBM WebSphere Message Broker component DatabaseInstanceMgr6
IBM WebSphere Message Broker component WBRK61_DEFAULT_BROKER
IBM WebSphere Message Broker component WBRK61_DEFAULT_CONFIGURATION_MANAGER

but I've these alerts at the toolkit:

-Description: The broker is not running, Resource: WBRK61_DEFAULT_BROKER, In Domain: WBRK61_DEFAULT_QUEUE_MANAGER@localhost:2414
-Description: The execution group is not running, Resource: WBRK61_DEFAULT_BROKER/default, In Domain: WBRK61_DEFAULT_QUEUE_MANAGER@localhost:2414

Also when I try the "mqsilist" I get the following lines in the command console:

"Error in event log... ReportEvent() failed
BIP8081 An exception was caught while processing the response message for the command, 'Unable to format an ImbException message for output, ImbException message number is BIP2130'."

I've reinstalled the package and the problem is still there.

Please help

Thanks
Back to top
View user's profile Send private message
NewYa3am
PostPosted: Wed Oct 14, 2009 7:26 am Post subject: Reply with quote

Newbie

Joined: 14 Oct 2009
Posts: 8

Also when I try this:

C:\Program Files\IBM\MQSI\6.1>mqsideploy -i localhost -p 2414 -q WBRK61_DEFAULT
_QUEUE_MANAGER -b WBRK61_DEFAULT_BROKER

The following is what I get:

Error in event log... ReportEvent() failed
BIP1044I: Connecting to the Configuration Manager's queue manager...
BIP1045I: Connecting to the Configuration Manager...
BIP1026I: Deploying configuration information to broker 'WBRK61_DEFAULT_BROKER'...
BIP1100E: Broker WBRK61_DEFAULT_BROKER had not responded before the timeout occurred.
Back to top
View user's profile Send private message
Vitor
PostPosted: Wed Oct 14, 2009 7:30 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25841
Location: Texas, USA

Sounds a lot like the broker's not running properly to me. Perhaps if you looked in the Event Viewer you might find a clue...
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
NewYa3am
PostPosted: Wed Oct 14, 2009 8:08 am Post subject: Reply with quote

Newbie

Joined: 14 Oct 2009
Posts: 8

Thanks for your reply.

I've found these errors in the event viewer:

Quote:
( WBRK61_DEFAULT_BROKER ) Broker 'WBRK61_DEFAULT_BROKER' could not process an internal configuration message.

The problem was caused by a failure to parse the internal configuration message. The internal configuration message is rejected.


Quote:
( WBRK61_DEFAULT_BROKER ) Error '4' converting a character string to or from codepage '720'.

A character conversion between codepages has failed. This may be due to an invalid codepage being specified in the header of a message, or may be due to a character being present in a message that does not appear in the required codepage conversion table.

Check that the application that generated the message is using a valid codepage in the message header and that all characters used are valid in that codepage.


Quote:
( WBRK61_DEFAULT_BROKER ) An unexpected exception ''unknown'' was caught.

The broker caught an unexpected exception.
Back to top
View user's profile Send private message
NewYa3am
PostPosted: Wed Oct 14, 2009 8:11 am Post subject: Reply with quote

Newbie

Joined: 14 Oct 2009
Posts: 8

Sometimes I get the following message box:

Title Bar: biphttplistener.exe - Application Error
Body: The application failed to initialize properly (0xc0000142). Click on OK to terminate the application.
Back to top
View user's profile Send private message
mqmatt
PostPosted: Wed Oct 14, 2009 8:33 am Post subject: Re: BIP8081 & Broker isn't running but its service is st Reply with quote

Grand Master

Joined: 04 Aug 2004
Posts: 1213
Location: Hursley, UK

NewYa3am wrote:
WebSphere Message Broker, V6.1.0.0
WebSphere Message Broker Toolkit, V6.1.0

Apply maintenance - you should be on v6.1.0.5.
If the problem persists after you update, then raise a PMR.
Back to top
View user's profile Send private message
Vitor
PostPosted: Wed Oct 14, 2009 8:35 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25841
Location: Texas, USA

Having had a closer look at your earlier posts, what is that mqsideploy command supposed to be doing?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
mqmatt
PostPosted: Wed Oct 14, 2009 8:41 am Post subject: Reply with quote

Grand Master

Joined: 04 Aug 2004
Posts: 1213
Location: Hursley, UK

That mqsideploy is doing a broker configuration deploy. You need to do this if you change the broker's configuration options in the CM (e.g. runtime properties) but not yet sent them down to the broker.

For info, the ReportEvent() error in that command output means that mqsideploy couldn't write a message to the system log.
Right clicking on the Windows Application log, and enabling the property to "overwrite events as needed" should fix that. And making sure that the user running mqsideploy has sufficient authority on the system to do this.
Back to top
View user's profile Send private message
Vitor
PostPosted: Wed Oct 14, 2009 8:49 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25841
Location: Texas, USA

mqmatt wrote:
That mqsideploy is doing a broker configuration deploy. You need to do this if you change the broker's configuration options in the CM (e.g. runtime properties) but not yet sent them down to the broker.


Doh!
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
NewYa3am
PostPosted: Sun Oct 25, 2009 8:13 am Post subject: Reply with quote

Newbie

Joined: 14 Oct 2009
Posts: 8

Thanks mqmatt. Your suggestion worked for me for the part of "ReportEvent() error"
mqmatt wrote:
... For info, the ReportEvent() error in that command output means that mqsideploy couldn't write a message to the system log.
Right clicking on the Windows Application log, and enabling the property to "overwrite events as needed" should fix that. And making sure that the user running mqsideploy has sufficient authority on the system to do this.


I've the problem solved. Here is the steps I followed:
-Opened Control Panel > Regional and Language Options
-In "Advanced" tab, in "Language for non-Unicode programs" group, selected the language to be "English (United States)"
-Restarted computer
-Removed default configurations using the wizard
-Created the default configurations again using the wizard and all worked fine.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP8081 & Broker isn't running but its service is starte
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.