ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexSearch

Search found 35 matches
Author Message
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Mon Sep 21, 2020 5:50 am Subject: Issue while escaping special character in DFDL parser
If the delimiters can appear within the data then you definitely do require an escape scheme. Your current solution is not safe. It only appears to work correctly because your are not testing with dat ...
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Mon Sep 21, 2020 3:23 am Subject: Issue while escaping special character in DFDL parser
This application uses % and * as their field separatorsAre these fields variable-length? If so, please pick one of the following options:
a) the characters % and * can never, ever appear in the valu ...
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Sun Sep 20, 2020 9:43 pm Subject: Issue while escaping special character in DFDL parser
Thanks for the clear problem description - we appreciate it when people tell us what they have already tried. It saves our time as well as yours.

I can definitely help you with this, but first I wi ...
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Fri Sep 18, 2020 5:38 am Subject: Issue while escaping special character in DFDL parser
providing more information:

the escape scheme in my DFDL definition is as below:
<dfdl:defineEscapeScheme name="RecordEscapeScheme">
<dfdl:escapeScheme escapeKind="esc ...
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Fri Sep 18, 2020 4:33 am Subject: Issue while escaping special character in DFDL parser
So far I have tried escaping % in the following manner:
'%%'
'"%'
'"%"'
but nothing seems to work, everytime it just adds " before the entire text
Topic:Issue while escaping special character in DFDL parser
rahulk01

Replies: 9
Views: 3335

PostForum:WebSphere Message Broker Support Posted: Fri Sep 18, 2020 4:19 am Subject: Issue while escaping special character in DFDL parser
Hi,

I have a requirement where I am trying to set % in a text field, something like below:
SET rBelopRecord.RESERVASJONNR = 'O' || '%';

But after being validated by the DFDL parser in the outp ...
Topic:Trouble generating a Timestamp in GMT TZ
rahulk01

Replies: 4
Views: 1876

PostForum:WebSphere Message Broker Support Posted: Mon Jul 20, 2020 9:32 pm Subject: Trouble generating a Timestamp in GMT TZ
Apparently, this solved the issue:

$ vi $MQSI_WORKPATH/config/<IntegrationNode>/profiles/commonprofile.sh

edit TZ in file:
--------------------------------
export SPRING_PROFILES_ACTIVE ...
Topic:Trouble generating a Timestamp in GMT TZ
rahulk01

Replies: 4
Views: 1876

PostForum:WebSphere Message Broker Support Posted: Sun Jul 19, 2020 9:55 pm Subject: Trouble generating a Timestamp in GMT TZ
It's a regular compute node. I need to schedule a task 10 mins from now in the GMT TZ, as my scheduler works in GMT. So I am trying to get the current GMT Timestamp and add 10 mins to it and update it ...
Topic:Trouble generating a Timestamp in GMT TZ
rahulk01

Replies: 4
Views: 1876

PostForum:WebSphere Message Broker Support Posted: Sun Jul 19, 2020 9:08 am Subject: Trouble generating a Timestamp in GMT TZ
Hi,

I have a requirement where I need to get the current GMT Timestamp and store it in DB. My Broker is running in a TZ 2 hours ahead of GMT.
I have tried multiple options but nothing seems to wor ...
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Thu Jun 11, 2020 5:06 am Subject: SSL setup for HTTPS request from Linux to Mainframe
It was a case of incorrect certificate. After we got the correct certificates and imported into the truststore, it started to work.
Thanks for your inputs.
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Wed May 27, 2020 11:22 pm Subject: SSL setup for HTTPS request from Linux to Mainframe
Thanks for your reply.
Just got to know this morning, it is actually a self-signed ceritificate.
Will try the debugging options you have suggested.
Thanks
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Wed May 27, 2020 7:07 am Subject: SSL setup for HTTPS request from Linux to Mainframe
It's a CA signed certificate, and I have imported the entire chain of certificates into the IIB truststore i.e. Root, Intermediate and Issuing in the same order. Does the order of import of certificat ...
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Tue May 26, 2020 8:08 am Subject: SSL setup for HTTPS request from Linux to Mainframe
Taking your advise, I ran the below 2 commands:
Exporting self-signed certificate (from /var/mqsi/SSL):
keytool -export -alias ftmsmp -file selfsigned.cer -keystore keystore.jks
Importing the self- ...
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Sun May 24, 2020 9:26 am Subject: SSL setup for HTTPS request from Linux to Mainframe
I used the following sequence commands and each of them executed successfully:
Not sure what I have missed:

keytool -genkey -alias ftmsmp -keystore keystore.jks -keysize 2048 (and entered deta ...
Topic:SSL setup for HTTPS request from Linux to Mainframe
rahulk01

Replies: 9
Views: 5220

PostForum:WebSphere Message Broker Support Posted: Sat May 23, 2020 12:06 am Subject: SSL setup for HTTPS request from Linux to Mainframe
Hi,

I am trying to setup the SSL configuration to make HTTPS request. The IIB flow is running in a linux machiine and the webservice in mainframe (exposed via zOS connect).
I followed the steps de ...
Goto page 1, 2, 3  Next Page 1 of 3

Jump to:
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.