ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportSAP node deployment error while using same rfc id

Post new topicReply to topic
SAP node deployment error while using same rfc id View previous topic :: View next topic
Author Message
KavitaK_TW
PostPosted: Tue Dec 05, 2017 1:01 am Post subject: SAP node deployment error while using same rfc id Reply with quote

Newbie

Joined: 04 Dec 2017
Posts: 3

Hello All,

I am trying to deploy 2 message flows with SAP node which are using same SAP adapter connection and same rfc id.
but I am getting error as below

BIP5035E: The XMLNSC validator signalled that an error occurred at line 15 while validating a XML schema. The file being processed
was SapGIDocObj.xsd in library SAP_TEST_MSGSET.
The message from the XMLNSC validator is: sch-props-correct.2: A schema cannot contain two global components with the same
name this schema contains two occurrences of 'http://www.ibm.com/xmlns/prod/websphere/j2ca/sap/sapgidocObj,SapGIDocObj'.

Errors have occurred during the validation of a XML schema.

IIB V10

Appreciate your suggestions.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Tue Dec 05, 2017 3:19 am Post subject: Re: SAP node deployment error while using same rfc id Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19432
Location: LI,NY

KavitaK_TW wrote:
Hello All,

I am trying to deploy 2 message flows with SAP node which are using same SAP adapter connection and same rfc id.
but I am getting error as below

BIP5035E: The XMLNSC validator signalled that an error occurred at line 15 while validating a XML schema. The file being processed
was SapGIDocObj.xsd in library SAP_TEST_MSGSET.
The message from the XMLNSC validator is: sch-props-correct.2: A schema cannot contain two global components with the same
name this schema contains two occurrences of 'http://www.ibm.com/xmlns/prod/websphere/j2ca/sap/sapgidocObj,SapGIDocObj'.

Errors have occurred during the validation of a XML schema.

IIB V10

Appreciate your suggestions.

If you are using the same adapter you have to download both schemas in the adapter. You may need to use the adapter as a shared resource and the schemas as well.

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
KavitaK_TW
PostPosted: Tue Dec 05, 2017 4:35 am Post subject: Re: SAP node deployment error while using same rfc id Reply with quote

Newbie

Joined: 04 Dec 2017
Posts: 3

fjb_saper wrote:
KavitaK_TW wrote:
Hello All,

I am trying to deploy 2 message flows with SAP node which are using same SAP adapter connection and same rfc id.
but I am getting error as below

BIP5035E: The XMLNSC validator signalled that an error occurred at line 15 while validating a XML schema. The file being processed
was SapGIDocObj.xsd in library SAP_TEST_MSGSET.
The message from the XMLNSC validator is: sch-props-correct.2: A schema cannot contain two global components with the same
name this schema contains two occurrences of 'http://www.ibm.com/xmlns/prod/websphere/j2ca/sap/sapgidocObj,SapGIDocObj'.

Errors have occurred during the validation of a XML schema.

IIB V10

Appreciate your suggestions.

If you are using the same adapter you have to download both schemas in the adapter. You may need to use the adapter as a shared resource and the schemas as well.

Have fun




I have single schema. I have added same msg set in 2 message flows and trying to deploy it in same EG (integration server) on a Node. The reason is I need to prepare copy of existing environment to new environment.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Dec 06, 2017 8:40 am Post subject: Re: SAP node deployment error while using same rfc id Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19432
Location: LI,NY

KavitaK_TW wrote:

I have single schema. I have added same msg set in 2 message flows and trying to deploy it in same EG (integration server) on a Node. The reason is I need to prepare copy of existing environment to new environment.

Then you should have different adapters. Until the environments are separate you can set the same config on each adapter
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
KavitaK_TW
PostPosted: Fri Dec 08, 2017 5:14 am Post subject: Re: SAP node deployment error while using same rfc id Reply with quote

Newbie

Joined: 04 Dec 2017
Posts: 3

Thanks for the reply.
I have deployed the message flows on separate Integration server(EG) on same Node and it worked fine.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportSAP node deployment error while using same rfc id
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.