ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Application ServerWAS 8.5.5.8 - MQRC 2035

Post new topicReply to topic
WAS 8.5.5.8 - MQRC 2035 View previous topic :: View next topic
Author Message
gabrielj
PostPosted: Sun Oct 29, 2017 4:43 am Post subject: WAS 8.5.5.8 - MQRC 2035 Reply with quote

Novice

Joined: 16 Nov 2014
Posts: 20
Location: Muscut,Perth,Sydney,Bangalore,Hydrabad,Coimbatore

Recently we were migrated our websphere application server v8.0.0.3 to 8.5.5.8. One application was running which is using IBM MQ java API to connect one third party machine through MQ server connection channel.

Same application working good in v8.0.0.3, but same application is not connecting with MQ in v8.5.5.8. We are getting "MQRC 2035"(NOT AUTHORIZED).

Exact Error: "Could be configuarion, network or service availability issue. Root Cause: MQJE001: Completion Code '2', Reason '2035'".

Both older and newer version of application server running as "SYSTEM" user(Windows service).

It can be solve by adding the setmqauth at third party side. but we need some clarification why same application is not working on v8.5.5.8
Back to top
View user's profile Send private message
gbaddeley
PostPosted: Sun Oct 29, 2017 3:33 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1742
Location: Melbourne, Australia

Request the third party to locate the authorization failure in their MQ error logs. This will lead to whatever action needs to be taken.
The most likely cause is that the java userid has changed, or the third party has channel authentication that is now blocking you.
_________________
Glenn
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Mon Oct 30, 2017 4:27 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19432
Location: LI,NY

Although please make sure that you kept the same JAAS settings and check that you are populating the extended structure for the userid.(Equivalent of un-checking the compatible checkbox in MQExplorer).
With your new version of WAS there should be an attribute to specify at the connection factory level for that...

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
gabrielj
PostPosted: Mon Oct 30, 2017 5:17 am Post subject: Reply with quote

Novice

Joined: 16 Nov 2014
Posts: 20
Location: Muscut,Perth,Sydney,Bangalore,Hydrabad,Coimbatore

The issue got resolved after explicitly added the user id in MQEnvironment.

Hashtable<String, Object> mqht = new Hashtable<String, Object>();
mqht.put(CMQC.USER_ID_PROPERTY, userID);

http://www-01.ibm.com/support/docview.wss?uid=swg21138961
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Application ServerWAS 8.5.5.8 - MQRC 2035
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.