ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportMQ Z\OS 8.0 Compatabile with COBOL 4.x Version??

Post new topicReply to topic
MQ Z\OS 8.0 Compatabile with COBOL 4.x Version?? View previous topic :: View next topic
Author Message
narik
PostPosted: Thu Aug 17, 2017 2:02 pm Post subject: MQ Z\OS 8.0 Compatabile with COBOL 4.x Version?? Reply with quote

Novice

Joined: 29 Aug 2016
Posts: 12

Hi Team,

We are planning to upgrade MQ on Z\OS to v8.0 and we are on COBOL 4.X version.IBM saying as they didn't do testing with the mentioned COBOL version with V8.0 as COBOL has been out of support long time ago and MQ v8.0 came after that. So my question is does any one of guys have upgraded MQv8.0 with COBOL being on 4.X version?? is it successful .Please help.Thank you.

Regards,
narik
Back to top
View user's profile Send private message
gbaddeley
PostPosted: Thu Aug 17, 2017 5:01 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1700
Location: Melbourne, Australia

It may give a warm feeling if someone has done this, but IBM may not provide support if you have any issues with COBOL 4.X. If in doubt, talk to your IBM account rep.
_________________
Glenn
Back to top
View user's profile Send private message
Vitor
PostPosted: Fri Aug 18, 2017 5:02 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 24448
Location: Ohio, USA

gbaddeley wrote:
It may give a warm feeling if someone has done this, but IBM may not provide support if you have any issues with COBOL 4.X. If in doubt, talk to your IBM account rep.




There's no guarantee we're doing everything you're trying to do with MQ.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Fri Aug 18, 2017 5:15 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17384

And there's especially no guarantee that if someone did get it working, that it would ever work at your site.

If some version of COBOL, or COBOL in general, is out of support... then your time is much better spent upgrading COBOL to the most recent levels before you even start mucking with MQ.
_________________
Read, Think, Try, Repeat
Back to top
View user's profile Send private message
narik
PostPosted: Fri Aug 18, 2017 12:16 pm Post subject: Reply with quote

Novice

Joined: 29 Aug 2016
Posts: 12

Thanks for all your responses. unfortunately our management is reluctant to upgrade COBOL now and yes i know its out of support.My only request is whether some one did tried mq v8.0 with COBOL 4.X ?
Back to top
View user's profile Send private message
gbaddeley
PostPosted: Sun Aug 20, 2017 4:44 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1700
Location: Melbourne, Australia

narik wrote:
Thanks for all your responses. unfortunately our management is reluctant to upgrade COBOL now and yes i know its out of support.My only request is whether some one did tried mq v8.0 with COBOL 4.X ?

Inform management of the risks of running unsupported software or combinations. It will then be their neck on the line.
_________________
Glenn
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Aug 21, 2017 5:11 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 24448
Location: Ohio, USA

narik wrote:
our management is reluctant to upgrade COBOL now


When do they plan to do it? In a panic 30 seconds after something critical fails or in a panic when they discover it's not supported on the z hardware upgrade they need?

narik wrote:
yes i know its out of support.


Do they? Specifically, do they know the level of business risk they're signing up to? Not just by introducing MQv8 but generally by running what I assume to be business critical systems on OOS COBOL?

(I assume they're business critical as there wouldn't be this management fear if they weren't)

This is exactly the sort of thing that will come back on you if you don't have proper signoff. One big problem and the same people who were "reluctant" to update COBOL will be the same people saying it's your fault for "not adequately articulating the technical situation". Seen it happen too many times.

narik wrote:
My only request is whether some one did tried mq v8.0 with COBOL 4.X ?


The lack of response is your answer I fear.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportMQ Z\OS 8.0 Compatabile with COBOL 4.x Version??
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.