ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Application Serverjava.net.SocketException: java.lang.ClassNotFoundException:

Post new topicReply to topic
java.net.SocketException: java.lang.ClassNotFoundException: View previous topic :: View next topic
Author Message
sankarisasmal
PostPosted: Tue Oct 13, 2015 10:01 am Post subject: java.net.SocketException: java.lang.ClassNotFoundException: Reply with quote

Newbie

Joined: 13 Mar 2015
Posts: 9

From our application we download a document from a webservice call which is through SSL(https). But the issue is not consistent and we intermittently get the following error. But sometimes we are successful.We we get the following error:

java.net.SocketException: java.lang.ClassNotFoundException: com.ibm.websphere.ssl.protocol.SSLSocketFactory

Stack Trace:
AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: java.net.SocketException: java.lang.ClassNotFoundException: com.ibm.websphere.ssl.protocol.SSLSocketFactory
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}stackTrace: java.net.SocketException: java.lang.ClassNotFoundException: com.ibm.websphere.ssl.protocol.SSLSocketFactory

This is happening in our production env only. The other lower environments look good.
Please let us know any resolution..
Back to top
View user's profile Send private message
Gaya3
PostPosted: Tue Oct 13, 2015 10:08 am Post subject: Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

did you check the jre version of non-prod and production.

is this application running on WAS, I trust you are using IBM WAS JRE over here.
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
sankarisasmal
PostPosted: Tue Oct 13, 2015 10:39 am Post subject: Reply with quote

Newbie

Joined: 13 Mar 2015
Posts: 9

Yes,, we have the same version of jre..
and the application is running on WAS
Back to top
View user's profile Send private message
Gaya3
PostPosted: Tue Oct 13, 2015 11:16 am Post subject: Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

whats the WAS version

am not sure if you get a chance to go through this document

http://www-01.ibm.com/support/docview.wss?uid=swg21584437
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Application Serverjava.net.SocketException: java.lang.ClassNotFoundException:
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.