ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral DiscussionDelayed startup time on C# triggering application

Post new topicReply to topic
Delayed startup time on C# triggering application View previous topic :: View next topic
Author Message
Sudhir123
PostPosted: Mon Jan 07, 2013 4:05 pm Post subject: Delayed startup time on C# triggering application Reply with quote

Newbie

Joined: 07 Jan 2013
Posts: 1

I have a C# triggering application with triggering threshold depth of 1. I am referencing the amqmdnet.dll (file version - 1.0.0.3, product version - 7.0.1.6) in my C# app. The C# application processes a messages on the queue within 3-4 sec when executed from the command prompt. However there is a startup delay of 8-9 sec when the application is triggered from the MQ trigger monitor. I have tried several things to figure out what's going on without any success. Below is the configuration:

WebSphere MQ v7.0.1.6
CMVC level: p701-106-110725
BuildType: IKAP - (Production)
Platform: WebSphere MQ for Windows
Mode: 32-bit
O/S: Windows Ver 6.1 (7) Server Enterprise x64 Edition, Build 7601: SP1

C# Console application with build target X86 using .Net 3.5 (VS 2008) running on a 64 bit Windows 2008.

Here is what IBM had to say about it :

, it consistently takes 9 seconds from the point that the trigger
monitor issues the system command (to run it) to the actual execution of
the program, where it put out its first trace statement. The 9 seconds
is the time it must take for the system create a session for the program
complete with the .Net CLR, application code and load of non-managed
libraries. I suspect the faster load times when the program is run
directly from the command line are due to cacheing features within
Windows, that are not available when a .Net application is started
programmatically using the "system" api.

Any help would be appreciated. This is a production issue and I need to get this resolved ASAP.

Thanks!
Back to top
View user's profile Send private message
mqjeff
PostPosted: Mon Jan 07, 2013 4:17 pm Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

Turn your application into it's own trigger monitor?

Turn your application into a non-triggered always-running service application?

Use the .NET Monitor?
Back to top
View user's profile Send private message
bruce2359
PostPosted: Mon Jan 07, 2013 4:18 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 7847
Location: US: west coast, almost. Otherwise, enroute.

Moved to General forum.
_________________
I didn't know that Schrdinger had a cat.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral DiscussionDelayed startup time on C# triggering application
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.