ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportNot able to connect queue manager

Post new topicReply to topic
Not able to connect queue manager View previous topic :: View next topic
Author Message
amondal
PostPosted: Thu Aug 30, 2001 10:51 am Post subject: Reply with quote

Newbie

Joined: 29 Aug 2001
Posts: 3

My eGate(EAI product from Seebeyond) program is not able to connect queue manager. But I checked queue manager is running. When I am running sample program (from MQSeries) it is running fine. Here I am attaching relevant portion of log files from two systems.

eGate log
=====================================
MNK E 1 (monklog:406): MQCONN: MQ connection failure: Reason:[2059] ==> MQRC_Q_MGR_NOT_AVAILABLE
EWY E 1 (monkmq.c:900): MQCONN: MQ connection failure: Reason: [2059] ==> MQRC_Q_MGR_NOT_AVAILABLE
MNK I 1 (monklog:406): [++] Failed to connect to queue manager: AIXDC61


MQSeries First Failure Symptom Report
=====================================
Date/Time :- Tuesday August 28 18:12:13 CDT 2001
Host Name :- aixdc61 (AIX 4.3)
PIDS :- 5765B73
LVLS :- 520
Product Long Name :- MQSeries for AIX
Vendor :- IBM
Probe Id :- XY341019
Application Name :- MQM
Component :- RetryConnectToSharedSubpool
Build Date :- Nov 7 2000
CMVC level :- p000-L001106
Build Type :- IKAP - (Production)
UserID :- 00000207 (ltmh_dev)
Program Name :- stcewgenericmonk
Process :- 00081992
Thread :- 00000001
Major Errorcode :- Unknown(20806206)
Minor Errorcode :- OK
Probe Type :- INCORROUT
Probe Severity :- 2
Probe Description :- AMQ6125: An internal MQSeries error has occurred.



MQM Function Stack
ConnectToSharedSubpool
RetryConnectToSharedSubpool
xcsFFST

Back to top
View user's profile Send private message Send e-mail
bduncan
PostPosted: Thu Aug 30, 2001 12:50 pm Post subject: Reply with quote

Padawan

Joined: 11 Apr 2001
Posts: 1554
Location: Silicon Valley

amondal,
I am actually currently working on eGate communicating with MQSeries, so I might be able to help you. But I need to know a few things first.
What version of eGate are you using? When you installed the MQSeries eWay, did you specify the AIX platform? Also, is the eWay trying to publish to MQSeries or subscribe from it?


_________________
Brandon Duncan
IBM Certified MQSeries Specialist
MQSeries.net forum moderator
Back to top
View user's profile Send private message Visit poster's website AIM Address
amondal
PostPosted: Thu Aug 30, 2001 1:32 pm Post subject: Reply with quote

Newbie

Joined: 29 Aug 2001
Posts: 3

Hi Brandon,
My eGate version is 4.12(AIX 4.3) and MQSeries version is 5.2
Installation order as follows:
1. eGate without MQ eWay.
2. MQSeries
3. MQ eWay

I have to send message to MQSeries queue and have to receive message also. I am not using pub/sub component of MQSeries.

I am receiving error message when it is trying to connect queue manager from eWay environment initialization function.

Thanks
Asim Mondal
Back to top
View user's profile Send private message Send e-mail
bower5932
PostPosted: Tue Sep 04, 2001 10:35 am Post subject: Reply with quote

Jedi Knight

Joined: 27 Aug 2001
Posts: 3023
Location: Dallas, TX, USA

I believe the probeid that you are seeing indicates problems with the AIX shared memory segment being in use. With MQSeries 5.2, the AIX shared segment address is configurable. Update the QueueManager stanza in the mqs.ini file:

QueueManager:
IPCCBaseAddress=9

You can add the IPCCBaseAddress line below the lines that are already there. Valid values are 4 to 12, except 6 and 7.
Back to top
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger
amondal
PostPosted: Thu Sep 06, 2001 9:18 am Post subject: Reply with quote

Newbie

Joined: 29 Aug 2001
Posts: 3

Thanks a lot.

It is working now. I used IPCCBaseAddress=12.

Again Thanks a lot.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportNot able to connect queue manager
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.