ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Java / JMSMQ Series 5.2 and Java 1.2.2 - not working

Post new topicReply to topic
MQ Series 5.2 and Java 1.2.2 - not working View previous topic :: View next topic
Author Message
roliv
PostPosted: Mon Aug 27, 2001 5:09 pm Post subject: Reply with quote

Novice

Joined: 26 Aug 2001
Posts: 11

Hi,
I have the latest MQSeries classes for Java (MA88, version 5.2) installed on a machine running AIX 4.3.3 and MQSeries 5.2. I have IBM's jdk 1.1.8 and IBM's jdk 1.2.2 installed on this machine too. If I use the JVM for java 1.1.8 to run my program, everything works fine. However, if I use the JVM for java 1.2.2, I get the following error when trying to connect to the MQQueueManager:

MQ Exception - com.ibm.mq.MQException: Completion Code 2, Reason 2059

Does anyone have had the same problem? Is it required to configure MQSeries 5.2 in a special way so it can work with jdk 1.2.2?

I running out of ideas; any help would be appreciated. Thanks!
Back to top
View user's profile Send private message
kolban
PostPosted: Mon Aug 27, 2001 5:26 pm Post subject: Reply with quote

Grand Master

Joined: 22 May 2001
Posts: 1072
Location: Fort Worth, TX, USA

I have succesfully used MQ Java classes with many JVMs including 1.2.2. When you switch from 1.1.8 to 1.2.2, what else did you change?

The 2059 error describes an inability to connect to the target, named queue manager.

Explore carefully the differencies between a working 1.1.8 solution and a failing 1.2.2 solution. Look at CLASSPATH and more.

Worst case, run an MQ Java trace and see what is happening when the MQQueueManager connect method is called.

Back to top
View user's profile Send private message
john_bazeley
PostPosted: Mon Aug 27, 2001 5:28 pm Post subject: Reply with quote

Newbie

Joined: 25 Aug 2001
Posts: 6
Location: New Zealand

This is a known issue with AIX / MQ and JDKs.

There's a few words on the subject at http://www-4.ibm.com/software/ts/mqseries/library/manual01/en_US/aqm7aq01/aqm7aq.html

What you can do is:
1. Add the shared memory hacks described to mqs.ini
2. Use TCP/IP mode rather than binding mode to connect to the QM.

You may have more joy with (2)
Back to top
View user's profile Send private message
roliv
PostPosted: Mon Aug 27, 2001 6:36 pm Post subject: Reply with quote

Novice

Joined: 26 Aug 2001
Posts: 11

Thanks for your replies.

kolban - Was AIX 4.3.3 the platform on which MQSeries 5.2 and jdk 1.2.2 were running? I have MQSeries and jdk 1.2.2 installed on my laptop (Windows 2000) and they work well on this system.

john_bazeley - Thanks for sending the URL. Finally I know I am not alone. You are right about using client mode. That one works fine; the problem happens when I try to use bindings mode. I'll try to change mqs.ini file.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Java / JMSMQ Series 5.2 and Java 1.2.2 - not working
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.