ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportWebsphere MQ 9 - Command Server not starting automatically

Post new topicReply to topic
Websphere MQ 9 - Command Server not starting automatically View previous topic :: View next topic
Author Message
jstrahn
PostPosted: Wed Nov 08, 2017 9:47 am Post subject: Websphere MQ 9 - Command Server not starting automatically Reply with quote

Newbie

Joined: 29 Jan 2004
Posts: 9

For some reason, my command server is not starting automatically when I start my queue manager.

OS: AIX
WebSphere MQ 9

If I manually execute strmqcsv MCPR004, the command server starts fine and I'm able to then connect via MQExplorer.

Is there a setting within the queue manager that suppresses the command server from starting when the queue manager starts up?

I thought by default it was supposed to start automatically.
Back to top
View user's profile Send private message
jstrahn
PostPosted: Wed Nov 08, 2017 9:57 am Post subject: Reply with quote

Newbie

Joined: 29 Jan 2004
Posts: 9

I actually see now that SCMDSERV holds the value as to whether the command server is started when the queue manager starts.

On my queue manager, it is set to manual. Can someone advise me the syntax to update the value to automatically start?
Back to top
View user's profile Send private message
exerk
PostPosted: Wed Nov 08, 2017 10:06 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5756

Try THIS...
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
jstrahn
PostPosted: Wed Nov 08, 2017 10:10 am Post subject: Reply with quote

Newbie

Joined: 29 Jan 2004
Posts: 9

Thank you. I was confused that the two values were manual or qmgr. I've changed it to qmgr and the command server is now starting when my queue manager starts up. Thank you.
Back to top
View user's profile Send private message
exerk
PostPosted: Wed Nov 08, 2017 11:48 am Post subject: Re: Websphere MQ 9 - Command Server not starting automatical Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5756

jstrahn wrote:
...I thought by default it was supposed to start automatically.

It's possible that if you have automated queue manager build that the change to manual is scripted. That or it was manually changed post-creation.
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportWebsphere MQ 9 - Command Server not starting automatically
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.