ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker Supportuse HTTPConnector

Post new topicReply to topic
use HTTPConnector View previous topic :: View next topic
Author Message
jgoldberg
PostPosted: Mon Apr 11, 2011 7:03 pm Post subject: use HTTPConnector Reply with quote

Newbie

Joined: 14 Mar 2011
Posts: 9

in the documentation for using the embedded http connector instead of the broker httplistener, it states "You must include both the HTTPInput and HTTPReply nodes in the same message flow, or deploy separate message flows to the same execution group, so that they use the same listener; matching input and reply messages must be processed by the same port."

I have a set of flows in the same execution group that run smoothly under the broker http listener. When I switch to use the embedded connector I get an error in my HTTPReply node "need return context info." I am passing it back to the node as a blob, and it DOES work properly with the broker-wide http listener. Is the documentation misleading me again? Can this actually work with multiple flows in the same execution group and the problem is I'm missing some important configuration step? To enable it I use just what's in the docs:

mqsichangeproperties tb2 -b httplistener -o HTTPListener -n startListener -v false
mqsichangeproperties tb2 -e ex2 -o ExecutionGroup -n httpNodesUseEmbeddedListener -v true
mqsistop tb2
mqsistart tb2

Am I SOL with embedded http connector unless I move everything into a single flow?
Back to top
View user's profile Send private message
balasabarish
PostPosted: Fri Jul 07, 2017 8:22 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2014
Posts: 1

Hi,
I am facing the same problem.
working fine for broker wide listener but getting 'Need return context info' error while enabling the embedded listener.

Have you got any other solution apart from moving in to a single flow / thread?
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker Supportuse HTTPConnector
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.