ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportA subflow calling a Rest API doesn't get the response back

Post new topicReply to topic
A subflow calling a Rest API doesn't get the response back View previous topic :: View next topic
Author Message
souciance
PostPosted: Sat Jul 01, 2017 3:06 am Post subject: A subflow calling a Rest API doesn't get the response back Reply with quote

Apprentice

Joined: 29 Jun 2010
Posts: 41

Hello,

The basic structure looks like this:

Main flow --> subflow1 ---> RestRequestNode --> Internal Rest API --> subflowRest1 --> HTTPRequest --> output

I am expecting once HTTPRequest is done and enters the output of the subflow in the Rest API project it should return to the subflow1. However when debugging it simply terminates after the output of subflowRest1.

However, if I take all the nodes in subflow1 and put them in Main Flow, then everything works as expected. The message is returned and execution continues. What gives?

Can't a subflow handle calling a Rest API using the RestRequest Node?

Souciance
Back to top
View user's profile Send private message
souciance
PostPosted: Sat Jul 01, 2017 3:42 am Post subject: Reply with quote

Apprentice

Joined: 29 Jun 2010
Posts: 41

Replacing the subflows with Callable flows also works. So something about invoking subflows messes things up.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Sat Jul 01, 2017 6:46 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17384

Take a User Trace.
_________________
Read, Think, Try, Repeat
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportA subflow calling a Rest API doesn't get the response back
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.