ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB Integration Server not listening to the set port

Post new topicReply to topic
IIB Integration Server not listening to the set port View previous topic :: View next topic
Author Message
visitvivek1
PostPosted: Thu Apr 27, 2017 4:20 pm Post subject: IIB Integration Server not listening to the set port Reply with quote

Newbie

Joined: 27 Apr 2017
Posts: 3

Hi,
We have created an Integration Server and set httpsconnector to listen on embedded port 12207. But when I try to list the ports which are listening, this port is not listed.
When I check the properties of this Integration server, it shows -

mqsireportproperties ESMTINQ02 -e parts -o HTTPSConnector -a

HTTPSConnector
uuid='HTTPSConnector'
userTraceLevel='none'
traceLevel='none'
userTraceFilter='none'
traceFilter='none'
port='0'
address=''
maxPostSize=''
acceptCount=''
compressableMimeTypes=''
compression=''
connectionLinger=''
connectionTimeout=''
maxHttpHeaderSize=''
maxKeepAliveRequests='0'
maxThreads=''
minSpareThreads=''
noCompressionUserAgents=''
restrictedUserAgents=''
socketBuffer=''
tcpNoDelay='true'
explicitlySetPortNumber='12207'
enableLookups=''
enableMQListener=''
shutdownDelay=''
allowCrossConnectorPolling=''
autoRespondHTTPHEADRequests=''
integratedWindowsAuthentication=''
iwaTimeoutSeconds='300'
serverName=''
corsEnabled='false'
corsAllowOrigins='*'
corsAllowCredentials='false'
corsExposeHeaders='Content-Type'
corsMaxAge='-1'
corsAllowMethods='GET,HEAD,POST,PUT,PATCH,DELETE,OPTIONS'
corsAllowHeaders='Accept,Accept-Language,Content-Language,Content-Type'
algorithm=''
clientAuth=''
keystoreFile='/mqiib_ad01/iib/NODE_QA_2/mqsi/certs/NodeQA2KeystoreISparts.jks'
keystorePass='********'
keystoreType=''
truststoreFile=''
truststorePass=''
truststoreType=''
sslProtocol='TLS'
ciphers=''
keypass=''
keyAlias=''
sslSessionTimeout=''
crlFile=''
propagateClientCert=''
sessionCacheSize=''

When I compared it with other Integration Server which is working fine, I observed that the other IS has port=12205 and explicitlySetPortNumber=12205.
Am I missing something here? Why my IS shows 'port=0' and explicitlySetPortNumber=12207?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Apr 27, 2017 4:35 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 18994
Location: LI,NY

instead of running the command with -a you might want to try it with -r.

If there is no URL showing in the response, it means that you have no flow deployed that would be listening on that URL... so the port is set but not in use...

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
visitvivek1
PostPosted: Thu Apr 27, 2017 4:40 pm Post subject: Update on below topic Reply with quote

Newbie

Joined: 27 Apr 2017
Posts: 3

I observed that the Keystore path was wrong in the below setting and it is rectified now. Still I am getting this problem.
Back to top
View user's profile Send private message
visitvivek1
PostPosted: Thu Apr 27, 2017 4:46 pm Post subject: Reply with quote

Newbie

Joined: 27 Apr 2017
Posts: 3

There are many flows deployed on this IS. As I said, I am not sure if 'port=0' and ' explicitlySetPortNumber=12207' is causing this.
I am also not sure how to set both these properties to 12207?
Because on the other IS, I could see that both port and explicitlySetPortNumber are set to 12205 and it is working fine.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Sat Apr 29, 2017 3:12 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 18994
Location: LI,NY

Set the port property to 12207 and bounce the integration server (execution group).
If need be bounce the broker.

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
zpat
PostPosted: Thu May 04, 2017 12:07 am Post subject: Reply with quote

Jedi Council

Joined: 19 May 2001
Posts: 5378
Location: UK

I believe it won't open the port until a flow with an input node using http is running.
_________________
Well, I don't think there is any question about it. It can only be attributable to human error. This sort of thing has cropped up before, and it has always been due to human error.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Thu May 04, 2017 4:04 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17092

zpat wrote:
I believe it won't open the port until a flow with an input node using http is running.


... I thought that depended on version... ?
_________________
Read, Think, Try, Repeat
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB Integration Server not listening to the set port
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.