ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportHL7DFDLInput Node assigns the same Id to 2 differnt messages

Post new topicReply to topic
HL7DFDLInput Node assigns the same Id to 2 differnt messages View previous topic :: View next topic
Author Message
codemonkey85
PostPosted: Fri Apr 28, 2017 6:37 am Post subject: HL7DFDLInput Node assigns the same Id to 2 differnt messages Reply with quote

Newbie

Joined: 06 Feb 2014
Posts: 5
Location: UK

Hi,

When testing with the HL7DFDLInput node on IIB 9.0.0.5, I noticed when using the hcp testing utility and sending multiple files, IIB is not able to correlate every 2nd message e.g. replies for messages 1,3,5,7 are all fine, however the replies for messages 2,4,6,8 are not received.

When debugging, I can see that the same Id in the LocalEnvironment comes through for each 2 messages. Therefore the acknowledgement for the 2nd message is not processed successfully since it has the Id of the 1st message.

Anyone else come across this?

Thanks
_________________
"I don't know if you heard but...I did over 1000"
Back to top
View user's profile Send private message
timber
PostPosted: Fri Apr 28, 2017 8:52 am Post subject: Reply with quote

Yatiri

Joined: 25 Aug 2015
Posts: 600

Could be a defect. Have you tried on a later fix pack?
Back to top
View user's profile Send private message
codemonkey85
PostPosted: Tue May 02, 2017 12:04 am Post subject: Reply with quote

Newbie

Joined: 06 Feb 2014
Posts: 5
Location: UK

Hi,

Thanks for your reply.

It turns out, I had to set the 'Record definition' setting on the TCPIP Server Output node to 'Record is Unmodified Data' when sending back the ack message in order to resolve this issue. It was previously set as 'Record is Delimited Data' with the 1C0D set as the custom delimiter.

Thanks
_________________
"I don't know if you heard but...I did over 1000"
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportHL7DFDLInput Node assigns the same Id to 2 differnt messages
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.