ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportChinese/Japanese Characters DB fetch Issue

Post new topicReply to topic
Chinese/Japanese Characters DB fetch Issue View previous topic :: View next topic
Author Message
Swati01June
PostPosted: Sun Apr 16, 2017 9:31 pm Post subject: Chinese/Japanese Characters DB fetch Issue Reply with quote

Newbie

Joined: 16 Apr 2017
Posts: 1

Whenever we are trying to fetch Databse records which contains Chinese/Japanese characters we are getting a null resultset.
We tries various code pages like UTf-8,UTF-16 and japanese /chinese character specif encoding in esql code as well as in odbc.ini but it did not work.
We are using IIB10.0.0.2
database details:
databaseProviderVersion = 12.01.0000 Oracle 12.1.0.2.0
driverVersion = 07.15.0234 (B0239, U0164)
driverOdbcVersion = 03.52
---------------------------------------------
IANAAppCodePage=106(in odbc.ini)
---------------------------------
locale settings
LC_ALL=en_US.utf8
LANG=en_US.utf8
Back to top
View user's profile Send private message
smdavies99
PostPosted: Sun Apr 16, 2017 10:03 pm Post subject: Reply with quote

Jedi Council

Joined: 10 Feb 2003
Posts: 6076
Location: Somewhere over the Rainbow this side of Never-never land.

Can a moderator please move this to the Message Broker forum.
_________________
WMQ User since 1999
MQSI/WBI/WMB/'Thingy' User since 2002
Linux user since 1995

Every time you reinvent the wheel the more square it gets (anon). If in doubt think and investigate before you ask silly questions.
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Apr 17, 2017 4:36 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 24330
Location: Ohio, USA

smdavies99 wrote:
Can a moderator please move this to the Message Broker forum.


So moved.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Apr 17, 2017 4:38 am Post subject: Re: Chinese/Japanese Characters DB fetch Issue Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 24330
Location: Ohio, USA

Swati01June wrote:
We tries various code pages like UTf-8,UTF-16 and japanese /chinese character specif encoding in esql code as well as in odbc.ini but it did not work.


I'm not entirely sure how you think that will help. If you're getting a null result set from Oracle, then it's going to be null when you process it.

What does your Oracle DBA say about this? What's the native code page of the database in question.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportChinese/Japanese Characters DB fetch Issue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.