ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ File Transfer EditionMQ FTE agent creation error

Post new topicReply to topic
MQ FTE agent creation error View previous topic :: View next topic
Author Message
SpringPearl
PostPosted: Thu Feb 09, 2017 3:18 am Post subject: MQ FTE agent creation error Reply with quote

Novice

Joined: 07 Dec 2016
Posts: 10

I am doing a basic poc on MQ FTE. With very limited information that I got I used the following command to create co-ordination queue manager, command queue manager and agent:

1)fteSetupCoordination -coordinationQMgr corqm -coordinationQMgrHost localhost -coordinationQMgrPort 1417 -coordinationQMgrChannel FTE.CHANNEL.SVRCONN -f

2) runmqsc corqm < corqm.mqsc

3) fteSetupCommands -connectionQMgr cmdqm -connectionQMgrHost localhost -connectionQMgrPort 1418 -connectionQMgrChannel FTE.CHANNEL.SVRCONN -f

4) fteCreateAgent -agentName AGENT1 -agentQMgr agentqm -agentQMgrHost localhost -agentQMgrPort 1419 -agentQMgrChannel SYSTEM.DEF.SVRCONN -f

When I run the 4th command I get this error:

BFGMQ1024I: The coordination queue manager cannot be contacted or has refused a connection attempt.
The WebSphere MQ reason code was 2538 and diagnostic message code was AMQ9213. The agent's presence will not be published.
BFGCL0254I: Agent configured successfully. The agent has not been registered with the coordination queue manager.

Also when I tried to connect the managed file transfer configuration corqm in the MQ Explorer GUI it is throwing 2035 error

The TCP listeners with port 1417,1418,1419 are all up and running.

Please let me know if u need any more info on what I have done.

I have been breaking my head over it for a week now. Any help is appreciated. Thanks!

[/img]


Last edited by SpringPearl on Thu Feb 09, 2017 3:49 am; edited 1 time in total
Back to top
View user's profile Send private message
exerk
PostPosted: Thu Feb 09, 2017 3:36 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5756

It would be of great help if you stated your platform and MQ version.

It would be of great help if you stated your configuration, e.g. all queue managers on the same host or split between hosts.

It would be of great help if you stated what you have done, up to this point, to fault diagnose and the result, if any, of that diagnosis.

In short, the more information we have up front, the greater chance of providing help.
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
SpringPearl
PostPosted: Thu Feb 09, 2017 3:46 am Post subject: Reply with quote

Novice

Joined: 07 Dec 2016
Posts: 10

exerk wrote:
It would be of great help if you stated your platform and MQ version.

It would be of great help if you stated your configuration, e.g. all queue managers on the same host or split between hosts.

It would be of great help if you stated what you have done, up to this point, to fault diagnose and the result, if any, of that diagnosis.

In short, the more information we have up front, the greater chance of providing help.


Platform: Windows 7
MQ Version: 7.5
All the queue managers are on the same host.
I tried to run the commands as admin. Also I tried creating another SVRCONN channel and read through a lot of documents but to no avail

Also when I tried to connect the managed file transfer configuration in the MQ Explorer GUI it is throwing 2035 error
Back to top
View user's profile Send private message
exerk
PostPosted: Thu Feb 09, 2017 3:57 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5756

SpringPearl wrote:
Platform: Windows 7
MQ Version: 7.5
All the queue managers are on the same host.
I tried to run the commands as admin. Also I tried creating another SVRCONN channel and read through a lot of documents but to no avail

Also when I tried to connect the managed file transfer configuration in the MQ Explorer GUI it is throwing 2035 error

Read up on CHLAUTH...
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
gbaddeley
PostPosted: Thu Feb 09, 2017 2:52 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1742
Location: Melbourne, Australia

Quote:
fteSetupCoordination -coordinationQMgr corqm -coordinationQMgrHost localhost -coordinationQMgrPort 1417 -coordinationQMgrChannel FTE.CHANNEL.SVRCONN


Check the qmgr error logs.

Try using the sample connection test program with these parameters, eg.
amqscnxc -x localhost(1417) -c FTE.CHANNEL.SVRCONN corqm
If it fails, check the error logs in WebSphere MQ/errors.
_________________
Glenn
Back to top
View user's profile Send private message
SpringPearl
PostPosted: Fri Feb 10, 2017 12:08 am Post subject: Reply with quote

Novice

Joined: 07 Dec 2016
Posts: 10

Thanks a lot I have disabled the channel authorization and its working now. But I got another issue. I have created agents and started it, I have checked in the agent logs that the agent is successfully started but I don't see the agents in MQ explorer, also when I run fteListAgents it shows BFGCL0014W: No agents exist that match the current selection criteria.

Any idea how to resolve it?
Back to top
View user's profile Send private message
exerk
PostPosted: Fri Feb 10, 2017 1:13 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5756

SpringPearl wrote:
Thanks a lot I have disabled the channel authorization and its working now...

I suggested reading up on it, not disabling it. What happens when your 'fix' gets promoted to Production? Get it right now and promotion through the environments will be a breeze.

SpringPearl wrote:
...But I got another issue. I have created agents and started it, I have checked in the agent logs that the agent is successfully started but I don't see the agents in MQ explorer, also when I run fteListAgents it shows BFGCL0014W: No agents exist that match the current selection criteria...

Read THIS first, then if that doesn't give the result you're expecting paste the exact command you're using.
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ File Transfer EditionMQ FTE agent creation error
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.