ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportConnect Problem in MQ 5.1 on Solaris 8

Post new topicReply to topic
Connect Problem in MQ 5.1 on Solaris 8 View previous topic :: View next topic
Author Message
Debbie Meehan
PostPosted: Wed Nov 07, 2001 11:01 am Post subject: Reply with quote

Newbie

Joined: 06 Nov 2001
Posts: 4
Location: NYS Division of Criminal Justice Service

I'm running mq 5.1 csd07 on Solaris 8. I added a new unix user and gave him connect authority to the queue manager via setmqaut.

When the user tries to connect to the queue manager it fails with 2035 - not authorized.

dspmqaut shows the user has connect access.

Why is the connect failing?


Back to top
View user's profile Send private message Send e-mail
isreal
PostPosted: Wed Nov 07, 2001 11:37 am Post subject: Reply with quote

Novice

Joined: 18 Sep 2001
Posts: 22

You need to read the Quick start guide for MQ 5.1 It will explain the the user needs to be a part of the mqm group. Hope that helps!

[ This Message was edited by: isreal on 2001-11-07 11:39 ]
Back to top
View user's profile Send private message Visit poster's website
EddieA
PostPosted: Wed Nov 07, 2001 11:52 am Post subject: Reply with quote

Jedi

Joined: 28 Jun 2001
Posts: 2453
Location: Los Angeles

Debbie,

Firstly, did you restart the Queue manager after adding the user. On 5.1, it's the only way to get the information refreshed. On 5.2, there's a command to do it.

Next, are you sure that it's the Connect that's failing.

Did you give the user any mqi authorities to open and get/put to a queue.

Cheers,

_________________
Eddie Atherton
IBM Certified Solution Developer - WebSphere Message Broker V6.1
IBM Certified Solution Developer - WebSphere Message Broker V7.0
Back to top
View user's profile Send private message
Debbie Meehan
PostPosted: Thu Nov 08, 2001 7:59 am Post subject: Reply with quote

Newbie

Joined: 06 Nov 2001
Posts: 4
Location: NYS Division of Criminal Justice Service

I recycled the queue manager and it made no difference.

The user has "all" authority for the queue it will be writing to, but it's not getting past the connect. I logged on as that user and ran /opt/mqm/samp/bin/amqsput. The response is "MCONN ended with reason code 2035"

I don't plan on putting the user in the mqm group. That would give it full access to everything.
Back to top
View user's profile Send private message Send e-mail
EddieA
PostPosted: Thu Nov 08, 2001 8:08 am Post subject: Reply with quote

Jedi

Joined: 28 Jun 2001
Posts: 2453
Location: Los Angeles

Debbie,

Long shot, but try the following to make 100% sure MQ is seeing the same UserID that you think it is. Especially the cAsE.

Check the error logs to see if this has been logged. (I haven't fully researched why this isn't logged every time).

If there's nothing there, then turn on Authority events and take a look at the message generated. The useid should be fairly obvious.

Cheers,

_________________
Eddie Atherton
IBM Certified Solution Developer - WebSphere Message Broker V6.1
IBM Certified Solution Developer - WebSphere Message Broker V7.0
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportConnect Problem in MQ 5.1 on Solaris 8
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.